Posts tagged fastcgi does not work after plesk upgrade

can’t get fastcgi file info: dynamic, errno: 2

If you are getting the above while restarting the httpd service on your plesk server then it means that plesk has been upgraded on your server and the problem is with the incorrect path for CGI_PHP_BIN variable in /etc/psa/psa.conf file.

for example :

root@server[#] grep CGI_PHP_BIN /etc/psa/psa.conf
CGI_PHP_BIN dynamic

Follow the below steps to fix this issue :

root@server[#] vi /etc/psa/psa.conf
Search for the variable CGI_PHP_BIN

you will find the below entry

CGI_PHP_BIN dynamic

replace it with

CGI_PHP_BIN /var/www/cgi-bin/cgi_wrapper/cgi_wrapper

Then reconfigure Apache service with command:

/usr/local/psa/admin/sbin/websrvmng –v -a

finally restart apache service and it will work for you now

[root@server]# /etc/init.d/httpd restart
Stopping httpd: [ OK ]
 Starting httpd: [ OK ]

That’s all you are done.